页面

2009年3月5日

Apache2.2.x不支持php5.1.x的解决办法 - 已使用 Google 工具栏发送

近来安装apache服务器的时候,发现apache2.2竟然无法跟php5.1.6搭配起来,在网上搜了一下,找到了一些解决办法,现在粘贴如下:

1.  下载、安装

2.若apache出现错误信息:The Apache service named  reported the following error:
>>> httpd.exe: Syntax error on line 115 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/PHP5/php5apache2.dll into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3

目前apache2.2还不太支持php5.1.x,解决办法有两种:

    (1)自己在Windows下编译php5.1.x和Apache的源码包,对新手难度比较大。
    http://www.php.net/manual/en/install.windows.building.php

    (2)去http://snap.php.net下载php5.2.x的Windows二进制包,把包里的php5apache2_2.dll 文件Copy到php5.1.x目录里面。

下载地址(可右键下载): http://www.discuz.net/attachment.php?aid=45910

注意改这一行LoadModule php5_module .../php5/php5apache2_2.dll

3 .如果还不行,以下是解决办法:

  下载 http://www.phpv.net/php5apache2.dll-php5.1.x.rar并解压.共有三个文件.

      vcredist_x86.exe
     php5apache2.dll
     httpd.exe.manifest

     1).将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件.
     2).将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下.
     3).双击运行vcredist_x86.exe安装.(如果无法安装装vcredist_x86.exe,就下载一个.NET framework 2装上,当然就不用再装vcredist_x86.exe。)
        重启apache2.2

4. 如果不行可多试几次,以修复方式安装一下apache.

5 ,如果出现   could not bind to address 0.0.0.0.:80  no listening sockets available,shutting down  Unable to open logs 错误提示,可能是skype等软件占用了80端口,用netstat -a,  netstat -na看一下端口情况;还有一种可能是:你的apache已经打开了,你再次打开时会出现这个错误的,看一下进程里是不是有httpd.exe进程.  

测试是否安装成功

再按不上,上帝也无回天之术了,怪就怪WINDOWS吧!

没有评论: